2006-09-25

CUPS-PDF finally works on Ubuntu

For a long time, one of my Debian packages, cups-pdf, could not work on Ubuntu, because Ubuntu runs its CUPS daemon using a low-privilege user. I'm happy to report that this issue is finally resolved: following the release of CUPS 1.2, a simple solution was discovered by Andre Klitzing.

However, I only noticed this recently, after registering myself on Launchpad to respond to Ubuntu bugs affecting my Debian packages. Sigh! Perhaps notifying me earlier, via the Debian BTS, would have been a good idea?

Anyhow, after checking that the solution wouldn't break anything on the Debian side, I committed the fix to cups-pdf 2.4.1-2. Enjoy!